2007年1月17日

Sun JDK 1.5 與 Fedora Core 6

弄了兩天的 FC6 with Tomcat 5 後,終於發現這樣的組合跟本無法讓 Tomcat 5 正常運作。

不確定是不是 gcj 的關係,但是可以確定的是 Tomcat 5 無法正確的編譯 .jsp 檔案。在決定改用 Sun JDK 1.5 時又發現 Yum 只能配合第三方 Repository ( JPackage.org ) 才能安裝 Sun JDK,相較於 Gentoo 的內建與自動化安裝程序只能無奈的回報長官:『那個… 我不會用 Fedora ....

公司的網路很慢,慢到每次做 yum search 都得等好久,偶爾還會跑出一堆網路錯誤出來。生命,沒想到竟浪費在空虛的等待上。唉...

其他:

  1. 我覺得 yum search 的搜尋結果其實也蠻難理解的。
  2. 要不是 FC6 的 alternatives 機制卡在那邊,我早就自行裝上 .bin 版了… :(
※ 2007-01-19:
  1. 發現 Tomcat 5.5 在 JNDI 的設定方式和先前 5.0 時有所差異,因此最後直接從 apache 下載 tomcat.5.0.28.tar.gz 檔回來裝。反正就是放棄自動啟用 Tomcat 的 script ,一切由人工執行啟動作業。
  2. 到現在還是不知道為什麼 Fedora 預設的 Tomcat 及 java 環境無法正確的對 jsp 進行編譯(一堆 class 都無法正確被 import 起來)。